package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/(.+^[^\/]?)`)
var str = `http://5.172.194.247/~dtm/index.php/en/parts/engine`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}