re = /\/(.+^[^\/]?)/
str = 'http://5.172.194.247/~dtm/index.php/en/parts/engine'
# Print the match result
str.match(re) do |match|
puts match.to_s
end