$re = '/\/(.+^[^\/]?)/';
$str = 'http://5.172.194.247/~dtm/index.php/en/parts/engine';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);