using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(?:[^\/]*\/){0,3}[^\/]*$";
string input = @"A. http://two/three/four
B. http://two/three
C. http://two";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}