package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^\/]*\/){0,3}[^\/]*$`)
var str = `A. http://two/three/four
B. http://two/three
C. http://two`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}