$re = '/(?m)^(?:[^\/]*\/){0,3}[^\/]*$/';
$str = 'A. http://two/three/four
B. http://two/three
C. http://two';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);