package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<h1\s+)([^<]*?>)`)
var str = `<h1 class='' id='' title=''>Title1</h1>
<h1 class='' id='' title=''>Title2</h1>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}