re = /(<h1\s+)([^<]*?>)/
str = '<h1 class=\'\' id=\'\' title=\'\'>Title1</h1>
<h1 class=\'\' id=\'\' title=\'\'>Title2</h1>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end