package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<filename>[a-zA-Z]+)\d*\.\w+`)
var str = `myfile2.txt
myfileagain.doc
myfile33.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}