$re = '/(?<filename>[a-zA-Z]+)\d*\.\w+/m';
$str = 'myfile2.txt
myfileagain.doc
myfile33.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);