const regex = /(?<filename>[a-zA-Z]+)\d*\.\w+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<filename>[a-zA-Z]+)\\d*\\.\\w+', 'gm')
const str = `myfile2.txt
myfileagain.doc
myfile33.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}