import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)\\n.*$";
final String string = "Sample 1\n"
+ "James B. Lapointe\n"
+ "1481 Keyser Ridge Road\n"
+ "Archdale, NC 27263\n"
+ "Appartment Keyser Ridge Road\n"
+ "Archdale, NC 27263\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}