$re = '/^[-0-9*?]{5,}$/miu';
$str = '568955
456646666
5645998989
5689?45
59-*?
59*-8
-*?**
???????????
*-*-*??
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);