// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?miu)^[-0-9*?]{5,}$").unwrap();
let string = "568955
456646666
5645998989
5689?45
59-*?
59*-8
-*?**
???????????
*-*-*??
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}