#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)Version\s+([^,\s]*)"
Local $sString = "Version 03.06.07b.E, RELEASE SOFTWARE (fc1)" & @CRLF & _
"Version 03.06.07b.E RELEASE SOFTWARE (fc1)" & @CRLF & _
"version 1.3(2)ES3" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")