import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Version\\s+([^,\\s]*)";
final String string = "Version 03.06.07b.E, RELEASE SOFTWARE (fc1)\n"
+ "Version 03.06.07b.E RELEASE SOFTWARE (fc1)\n"
+ "version 1.3(2)ES3\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}