$re = '/Version\s+([^,\s]*)/i';
$str = 'Version 03.06.07b.E, RELEASE SOFTWARE (fc1)
Version 03.06.07b.E RELEASE SOFTWARE (fc1)
version 1.3(2)ES3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);