using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(car( [^ ]*){1,10} house)|(house( [^ ]*){1,10} car)";
string input = @"car word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 house
house word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 car
house word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 word 11 car";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}