$re = '/(car( [^ ]*){1,10} house)|(house( [^ ]*){1,10} car)/m';
$str = 'car word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 house
house word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 car
house word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 word 11 car';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);