package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(car( [^ ]*){1,10} house)|(house( [^ ]*){1,10} car)`)
var str = `car word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 house
house word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 car
house word1 word2 word3 word4 word5 word6 word7 word8 word9 word10 word 11 car`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}