using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z]*_[A-Z]*";
string input = @"es,es_ES.UTF-8,es_ES,spanish";
RegexOptions options = RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}