const regex = /[a-z]*_[A-Z]*/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-z]*_[A-Z]*', 'u')
const str = `es,es_ES.UTF-8,es_ES,spanish`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}