$re = '/[a-z]*_[A-Z]*/u';
$str = 'es,es_ES.UTF-8,es_ES,spanish';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);