using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"::\K\s+|\s*\n(?=[^:]*(\n|$))\s*";
string substitution = @"";
string input = @"dn: CN=Gast,CN=Users,DC=question,DC=local
changetype: add
objectClass: top
objectClass: person
objectClass: organizationalPerson
objectClass: user
cn: Gast
description::
Vm9yZGVmaW5pZXJ0ZXMgS29udG8gZsO8ciBHYXN0enVncmlmZiBhdWYgZGVuIENvbXB1dGVyIGJ6dy
4gZGllIERvbcOkbmU=
name: Gast
sAMAccountName: Gast
unicodePwd::IgA2AEcATQBNAHQANwBoADcAIgA=
userAccountControl:512";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}