import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "::\\K\\s+|\\s*\\n(?=[^:]*(\\n|$))\\s*";
final String string = "dn: CN=Gast,CN=Users,DC=question,DC=local\n"
+ "changetype: add\n"
+ "objectClass: top\n"
+ "objectClass: person\n"
+ "objectClass: organizationalPerson\n"
+ "objectClass: user\n"
+ "cn: Gast\n"
+ "description::\n"
+ " Vm9yZGVmaW5pZXJ0ZXMgS29udG8gZsO8ciBHYXN0enVncmlmZiBhdWYgZGVuIENvbXB1dGVyIGJ6dy\n"
+ " 4gZGllIERvbcOkbmU=\n"
+ "name: Gast\n"
+ "sAMAccountName: Gast\n"
+ "unicodePwd::IgA2AEcATQBNAHQANwBoADcAIgA=\n"
+ "userAccountControl:512";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}