#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\&)(?![^<]*>|[<>]*<\/)"
Local $sString = "& <a href="http://www.google.com?a=b&c=d"> & </a> &" & @CRLF & _
"& <a href="http://www.google.com?a=b&c=d"> & </a> &" & @CRLF & _
"&  &" & @CRLF & _
"& all the amps on this line should match [ & ] (&) [ &] ( & ) [& ] (& )[&] ( &) &" & @CRLF & _
"& <a href="http://www.google.com?a=b&c=d"> & </a> &" & @CRLF & _
"& <a href="http://www.google.com?a=b&c=d"> & </a> && <a href="http://www.google.com?a=b&c=d"> & </a> && <a href="http://www.google.com?a=b&c=d"> & </a> &" & @CRLF & _
"& <a href="http://www.google.com?a=b&c=d"> & </a> &" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")