const regex = /(\&)(?![^<]*>|[<>]*<\/)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\&)(?![^<]*>|[<>]*<\\\/)', 'gi')
const str = `& <a href="http://www.google.com?a=b&c=d"> & </a> &
& <a href="http://www.google.com?a=b&c=d"> & </a> &
&  &
& all the amps on this line should match [ & ] (&) [ &] ( & ) [& ] (& )[&] ( &) &
& <a href="http://www.google.com?a=b&c=d"> & </a> &
& <a href="http://www.google.com?a=b&c=d"> & </a> && <a href="http://www.google.com?a=b&c=d"> & </a> && <a href="http://www.google.com?a=b&c=d"> & </a> &
& <a href="http://www.google.com?a=b&c=d"> & </a> &
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}