import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?'EMPTY'(\"\"))|'(?'recipe'(\\s*recipe\\[\\w+::\\w+@((?'MAJOR'(?:0|(?:[1-9]\\d*)))\\.(?'MINOR'(?:0|(?:[1-9]\\d*)))\\.(?'PATCH'(?:0|(?:[1-9]\\d*))))],*\\s*))+')$";
final String string = "\"\"\n"
+ "\"\" <-- Empty\n"
+ "'recipe[COOKBOOK::RECIPE_NAME@1.0.0],recipe[COOKBOOK::RECIPE_NAME@1.0.0],recipe[s::s@1.0.0]'\n"
+ "'recipe[COOKBOOK::RECIPE_NAME@1.0.0]'\n"
+ "'recipe[COOKBOOK::RECIPE_NAME@1.0.0], recipe[COOKBOOK::RECIPE_NAME@1.0.0]'\n"
+ "'recipe[COOKBOOK::RECIPE_NAME@11.10.10], recipe[COOKBOOK::RECIPE_NAME@11.10.10]'\n"
+ "'recipe[COOKBOOK::RECIPE_NAME@11.10.10]'\n"
+ "'recipe[cookbook::recipe]'\n"
+ "'recipe[somestring]'\n"
+ "'recipe[cookbook@1.0.0]'\n"
+ "'recipe[cookbook::recipe_name@1.0.0]'\n"
+ "'bsad'\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}