# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?'EMPTY'(\"\"))|'(?'recipe'(\s*recipe\[\w+::\w+@((?'MAJOR'(?:0|(?:[1-9]\d*)))\.(?'MINOR'(?:0|(?:[1-9]\d*)))\.(?'PATCH'(?:0|(?:[1-9]\d*))))],*\s*))+')$"
test_str = ("\"\"\n"
"\"\" <-- Empty\n"
"'recipe[COOKBOOK::RECIPE_NAME@1.0.0],recipe[COOKBOOK::RECIPE_NAME@1.0.0],recipe[s::s@1.0.0]'\n"
"'recipe[COOKBOOK::RECIPE_NAME@1.0.0]'\n"
"'recipe[COOKBOOK::RECIPE_NAME@1.0.0], recipe[COOKBOOK::RECIPE_NAME@1.0.0]'\n"
"'recipe[COOKBOOK::RECIPE_NAME@11.10.10], recipe[COOKBOOK::RECIPE_NAME@11.10.10]'\n"
"'recipe[COOKBOOK::RECIPE_NAME@11.10.10]'\n"
"'recipe[cookbook::recipe]'\n"
"'recipe[somestring]'\n"
"'recipe[cookbook@1.0.0]'\n"
"'recipe[cookbook::recipe_name@1.0.0]'\n"
"'bsad'\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.