const regex = /^((?'EMPTY'(""))|'(?'recipe'(\s*recipe\[\w+::\w+@((?'MAJOR'(?:0|(?:[1-9]\d*)))\.(?'MINOR'(?:0|(?:[1-9]\d*)))\.(?'PATCH'(?:0|(?:[1-9]\d*))))],*\s*))+')$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?\'EMPTY\'(""))|\'(?\'recipe\'(\\s*recipe\\[\\w+::\\w+@((?\'MAJOR\'(?:0|(?:[1-9]\\d*)))\\.(?\'MINOR\'(?:0|(?:[1-9]\\d*)))\\.(?\'PATCH\'(?:0|(?:[1-9]\\d*))))],*\\s*))+\')$', 'gm')
const str = `""
"" <-- Empty
'recipe[COOKBOOK::RECIPE_NAME@1.0.0],recipe[COOKBOOK::RECIPE_NAME@1.0.0],recipe[s::s@1.0.0]'
'recipe[COOKBOOK::RECIPE_NAME@1.0.0]'
'recipe[COOKBOOK::RECIPE_NAME@1.0.0], recipe[COOKBOOK::RECIPE_NAME@1.0.0]'
'recipe[COOKBOOK::RECIPE_NAME@11.10.10], recipe[COOKBOOK::RECIPE_NAME@11.10.10]'
'recipe[COOKBOOK::RECIPE_NAME@11.10.10]'
'recipe[cookbook::recipe]'
'recipe[somestring]'
'recipe[cookbook@1.0.0]'
'recipe[cookbook::recipe_name@1.0.0]'
'bsad'
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}