package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)\b(?:(?P<g0>1[\W_]*2[\W_]*3[\W_]*4[\W_]*5[\W_]*6[\W_]*7[\W_]*8)|(?P<g1>a[\W_]*s[\W_]*1[\W_]*2[\W_]*3[\W_]*4[\W_]*5[\W_]*6))\b`)
var str = ` sample 123 45 678 text
sample as123456 text
sample As123 456
sample bas123456 text NA
sample bas123 456ts text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}