const regex = new RegExp('(?i)\\b(?:(?P<g0>1[\\W_]*2[\\W_]*3[\\W_]*4[\\W_]*5[\\W_]*6[\\W_]*7[\\W_]*8)|(?P<g1>a[\\W_]*s[\\W_]*1[\\W_]*2[\\W_]*3[\\W_]*4[\\W_]*5[\\W_]*6))\\b', 'gm')
const str = ` sample 123 45 678 text
sample as123456 text
sample As123 456
sample bas123456 text NA
sample bas123 456ts text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}