import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\b(?:(?P<g0>1[\\W_]*2[\\W_]*3[\\W_]*4[\\W_]*5[\\W_]*6[\\W_]*7[\\W_]*8)|(?P<g1>a[\\W_]*s[\\W_]*1[\\W_]*2[\\W_]*3[\\W_]*4[\\W_]*5[\\W_]*6))\\b";
final String string = " sample 123 45 678 text\n"
+ " sample as123456 text\n"
+ " sample As123 456\n"
+ " sample bas123456 text NA\n"
+ " sample bas123 456ts text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}