package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\/start ([^_\r\n\t\f\v\s]*)(?:_(review))?`)
var str = `/start test-virojenie-12345_review`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}