const regex = /\/start ([^_\r\n\t\f\v\s]*)(?:_(review))?/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/start ([^_\\r\\n\\t\\f\\v\\s]*)(?:_(review))?', 'i')
const str = `/start test-virojenie-12345_review`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}