package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:\+33\s|0)[1-9](?:\s\d{2}){4})$`)
var str = `06 12 34 56 78
+33 4 12 34 56 78`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}