$re = '/^((?:\+33\s|0)[1-9](?:\s\d{2}){4})$/m';
$str = '06 12 34 56 78
+33 4 12 34 56 78';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);