// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:\+33\s|0)[1-9](?:\s\d{2}){4})$").unwrap();
let string = "06 12 34 56 78
+33 4 12 34 56 78";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}