#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<="NULL","0","0","0",",","1",",)(?:"[^"]+",?)+(?=,"D\$")"
Local $sString = ""apple","NULL","0","0","0",",","1",","fruit","red","sweet","D$","object"" & @CRLF & _
""horse","NULL","0","0","0",",","1",","animal","large","tail","D$","object"" & @CRLF & _
""Los Angeles","NULL","0","0","0",",","1",","city","California","smoggy","entertainment","D$","location""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")