using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=""NULL"",""0"",""0"",""0"","","",""1"","",)(?:""[^""]+"",?)+(?=,""D\$"")";
string input = @"""apple"",""NULL"",""0"",""0"",""0"","","",""1"","",""fruit"",""red"",""sweet"",""D$"",""object""
""horse"",""NULL"",""0"",""0"",""0"","","",""1"","",""animal"",""large"",""tail"",""D$"",""object""
""Los Angeles"",""NULL"",""0"",""0"",""0"","","",""1"","",""city"",""California"",""smoggy"",""entertainment"",""D$"",""location""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}