import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\"NULL\",\"0\",\"0\",\"0\",\",\",\"1\",\",)(?:\"[^\"]+\",?)+(?=,\"D\\$\")";
final String string = "\"apple\",\"NULL\",\"0\",\"0\",\"0\",\",\",\"1\",\",\"fruit\",\"red\",\"sweet\",\"D$\",\"object\"\n"
+ "\"horse\",\"NULL\",\"0\",\"0\",\"0\",\",\",\"1\",\",\"animal\",\"large\",\"tail\",\"D$\",\"object\"\n"
+ "\"Los Angeles\",\"NULL\",\"0\",\"0\",\"0\",\",\",\"1\",\",\"city\",\"California\",\"smoggy\",\"entertainment\",\"D$\",\"location\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}