import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "trace\\=\\'(?<trace>[^\\']*)\\'errCode\\=\\'(?<err_code>[^\\']*)\\'dateTimeLocalTransaction\\=\\'(?<dateTimeLocalTransaction>[^\\']*)\\'dateTimeLocalTransactionTo\\=\\'(?<dateTimeLocalTransactionTo>[^\\']*)\\'selectedTerminalTypes\\=\\'(?<selectedTerminalTypes>[^\\']*)\\'UDPApproveTermID\\=\\'(?<UDPApproveTermID>[^\\']*)\\',\\s+dateEnd\\=(?<dateEnd>[^\\']*)\\',\\s+referenceID\\=\\'(?<referenceID>[^\\']*)\\',\\s+selectedFlowTypeMaps\\=(?<selectedFlowTypeMaps>[^\\]]*)";
final String string = "Arg[2]: NetworkPacket{trace='0'errCode=''dateTimeLocalTransaction='Mon May 30 00:00:00 IRDT 2022'dateTimeLocalTransactionTo='Mon May 30 23:59:59 USDT 2022'selectedTerminalTypes='[]'UDPApproveTermID='', dateEnd=null', referenceID='', selectedFlowTypeMaps=[]}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}