re = /trace\=\'(?<trace>[^\']*)\'errCode\=\'(?<err_code>[^\']*)\'dateTimeLocalTransaction\=\'(?<dateTimeLocalTransaction>[^\']*)\'dateTimeLocalTransactionTo\=\'(?<dateTimeLocalTransactionTo>[^\']*)\'selectedTerminalTypes\=\'(?<selectedTerminalTypes>[^\']*)\'UDPApproveTermID\=\'(?<UDPApproveTermID>[^\']*)\',\s+dateEnd\=(?<dateEnd>[^\']*)\',\s+referenceID\=\'(?<referenceID>[^\']*)\',\s+selectedFlowTypeMaps\=(?<selectedFlowTypeMaps>[^\]]*)/m
str = 'Arg[2]: NetworkPacket{trace=\'0\'errCode=\'\'dateTimeLocalTransaction=\'Mon May 30 00:00:00 IRDT 2022\'dateTimeLocalTransactionTo=\'Mon May 30 23:59:59 USDT 2022\'selectedTerminalTypes=\'[]\'UDPApproveTermID=\'\', dateEnd=null\', referenceID=\'\', selectedFlowTypeMaps=[]}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end