$re = '/trace\=\'(?<trace>[^\']*)\'errCode\=\'(?<err_code>[^\']*)\'dateTimeLocalTransaction\=\'(?<dateTimeLocalTransaction>[^\']*)\'dateTimeLocalTransactionTo\=\'(?<dateTimeLocalTransactionTo>[^\']*)\'selectedTerminalTypes\=\'(?<selectedTerminalTypes>[^\']*)\'UDPApproveTermID\=\'(?<UDPApproveTermID>[^\']*)\',\s+dateEnd\=(?<dateEnd>[^\']*)\',\s+referenceID\=\'(?<referenceID>[^\']*)\',\s+selectedFlowTypeMaps\=(?<selectedFlowTypeMaps>[^\]]*)/m';
$str = 'Arg[2]: NetworkPacket{trace=\'0\'errCode=\'\'dateTimeLocalTransaction=\'Mon May 30 00:00:00 IRDT 2022\'dateTimeLocalTransactionTo=\'Mon May 30 23:59:59 USDT 2022\'selectedTerminalTypes=\'[]\'UDPApproveTermID=\'\', dateEnd=null\', referenceID=\'\', selectedFlowTypeMaps=[]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);