#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)[\r\n]?BEGIN(?:(?!FALSE|END).)*?FALSE(?:(?!FALSE|END).)*?END"
Local $sString = "BEGIN" & @CRLF & _
"DESCRIPTION: 1234" & @CRLF & _
"BOOL:TRUE" & @CRLF & _
"END" & @CRLF & _
"BEGIN" & @CRLF & _
"DESCRIPTION: 4568" & @CRLF & _
"BOOL:TRUE" & @CRLF & _
"END" & @CRLF & _
"BEGIN" & @CRLF & _
"DESCRIPTION: 715310" & @CRLF & _
"BOOL:FALSE" & @CRLF & _
"END" & @CRLF & _
"BEGIN" & @CRLF & _
"DESCRIPTION: 12489453" & @CRLF & _
"BOOL:TRUE" & @CRLF & _
"END" & @CRLF & _
"BEGIN" & @CRLF & _
"DESCRIPTION: 41543" & @CRLF & _
"BOOL:FALSE" & @CRLF & _
"END"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)