import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\r\\n]?BEGIN(?:(?!FALSE|END).)*?FALSE(?:(?!FALSE|END).)*?END";
final String string = "BEGIN\n"
+ "DESCRIPTION: 1234\n"
+ "BOOL:TRUE\n"
+ "END\n"
+ "BEGIN\n"
+ "DESCRIPTION: 4568\n"
+ "BOOL:TRUE\n"
+ "END\n"
+ "BEGIN\n"
+ "DESCRIPTION: 715310\n"
+ "BOOL:FALSE\n"
+ "END\n"
+ "BEGIN\n"
+ "DESCRIPTION: 12489453\n"
+ "BOOL:TRUE\n"
+ "END\n"
+ "BEGIN\n"
+ "DESCRIPTION: 41543\n"
+ "BOOL:FALSE\n"
+ "END";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}