# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\r\n]?BEGIN(?:(?!FALSE|END).)*?FALSE(?:(?!FALSE|END).)*?END"
test_str = ("BEGIN\n"
"DESCRIPTION: 1234\n"
"BOOL:TRUE\n"
"END\n"
"BEGIN\n"
"DESCRIPTION: 4568\n"
"BOOL:TRUE\n"
"END\n"
"BEGIN\n"
"DESCRIPTION: 715310\n"
"BOOL:FALSE\n"
"END\n"
"BEGIN\n"
"DESCRIPTION: 12489453\n"
"BOOL:TRUE\n"
"END\n"
"BEGIN\n"
"DESCRIPTION: 41543\n"
"BOOL:FALSE\n"
"END")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.