import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.);(\\d{4});(\\d{8});([A-K]);(\\d{7,8});(\\d{8});([A-Z ]+);([ ,\\d]+);(\\d{8});(\\d);(\\d); *$";
final String string = "ä;1234;00126434;K;11821111;00000000;SOME TEXT ; 0;00000000;0;0;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}