const regex = /^(.);(\d{4});(\d{8});([A-K]);(\d{7,8});(\d{8});([A-Z ]+);([ ,\d]+);(\d{8});(\d);(\d); *$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.);(\\d{4});(\\d{8});([A-K]);(\\d{7,8});(\\d{8});([A-Z ]+);([ ,\\d]+);(\\d{8});(\\d);(\\d); *$', '')
const str = `ä;1234;00126434;K;11821111;00000000;SOME TEXT ; 0;00000000;0;0;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}