re = /^(.);(\d{4});(\d{8});([A-K]);(\d{7,8});(\d{8});([A-Z ]+);([ ,\d]+);(\d{8});(\d);(\d); *$/
str = 'ä;1234;00126434;K;11821111;00000000;SOME TEXT ; 0;00000000;0;0;'
# Print the match result
str.match(re) do |match|
puts match.to_s
end